Benutzerhandbuch:Grundlagen

From ADempiere ERP Wiki

Jump to: navigation, search

Contents

Grundlagen

Nach der erfolgreichen Anmeldung öffnet sich das ADempiere-Hauptfenster.

Hauptfenster

Hauptmenü

Unterhalb der Menüleiste befinden sich mehrere Register. Wählen Sie das Register Menü um das Hauptmenü zu öffnen:

Hauptmenü

Das Register Menü zeigt auf der rechten Seite alle Funktionen an, die Ihnen in der gewählten Rolle zur Verfügung stehen. Die Funktionen sind in einer Baumstruktur nach Bereichen gruppiert. So finden Sie zum Beispiel alle Funktionsaufrufe von der Angebotseinholung durch eine Ausschreibung über die Bestellung und den Wareneingang bis zur Lieferantenrechnung unter der Überschrift Beschaffung zusammengefasst. Selektieren Sie unten links unterhalb des Menübaumes das Auswahlfeld Gesamter Baum, um alle Zusammenfassungseinträge zu öffnen und einen Überblick über die Vielzahl der von ADempiere bereitgestellten Funktionen zu erhalten.

Suche

Es gibt einige ähnlich benannte Funktionen bzw. Menüelemente, die sich unterhalb verschiedener Zusammenfassungseinträge befinden können. Um das Auffinden zu erleichtern, können Sie im Feld Suche unten rechts einen Text eingeben - z.B. „bestell”. Drücken Sie die Eingabetaste. Das System durchsucht alle Menüeinträge und markiert den ersten, der „bestell” enthält (z.B. Bestellung aus Bedarf erzeugen). Diese Suche arbeitet unabhängig von Groß- oder Kleinschreibung.

Drücken Sie die Eingabetaste erneut, um den nächsten passenden Menüeintrag zu suchen . Öffnen Sie das gewählte Menüelement (z.B. Bestellung) mit der Eingabetaste in Kombination mit der Umschalt-, Alt- oder Strg-Taste oder aktivieren Sie es mit einem Mausklick.

Schnellstartleiste

Für häufig verwendete Menüelemente lassen sich Schnellstarter im linken Bereich des Fensters anlegen. Öffnen Sie dazu auf einem ausgewählten Menüelement das Kontextmenü mit der rechten Maustaste und wählen Sie Hinzufügen zur Schnellstartleiste: der neue Schnellstarter - z.B. Bestellung - wird auf der Schnellstartleiste links im Menüfenster erstellt.

Um die Breite dieses Bereiches anzupassen, bewegen Sie die Maus zwischen die beiden Bereiche. Wenn das entsprechende Symbol angezeigt wird, können Sie durch drücken der linken Maustaste diese Grenze verschieben.

Funktionsart

Vor jedem Eintrag im Hauptmenü finden Sie ein Symbol, das auf die Art der Funktion hinweist, die durch den Aufruf ausgeführt wird.

Fenster

Image:Iconwindow.png Dieses Symbol weist auf den Aufruf eines Fensters hin.

In einem Fenster werden Dokumente definiert – z.B. Aufträge mit Auftragskopf und Auftragspositionen - oder es werden Datensätze eingegeben – z.B. Stammdaten für Geschäftspartner.

[[Image:||
Fenster Auftrag
]]

Alle Fenster in ADempiere haben in etwa den gleichen Aufbau und werden auch auf die gleiche Weise bedient. Ganz oben finden Sie Menüleiste, darunter eine Symbolleiste mit einer Anzahl von Schaltflächen. Während sich die Inhalte und Felder ändern, bleiben diese Bereiche im Fenster konstant. Ein Fenster wird häufig durch mehrere Register auf der linken Seite in hierarchischer Weise (erkennbar an der Einrückung) strukturiert. Den größten Raum nimmt ein zweispaltiger Eingabebereich mit verscheidenen Arten von Eingabe- oder Auswahlfeldern ein. Unten befindet sich eine Zeile für Hinweistexte und daneben ein Feld mit einer Information zum Datensatz.

Hinweis: Die Anordnung von Registern und Feldern eines Fensters sind in der Datenbank definiert – im sogenannten Application Dictionary – und können vom SuperUser in ADempiere weitgehend angepasst werden.

Die folgenden Abschnitte beschreiben die einzelnen Bereiche.

Menüleiste

Menü
Menüpunkt
Symbol
Kurzbefehl
Beschreibung
Datei Alt-D
Bildschirm drucken Image:PrintScreen24.png Druck Bildschirm drucken
Bildschirm-Kopie Image:ScreenShot24.png Umschalt-Druck Bildschirmkopie erstellen
Bericht Image:Report24.png F11 Bericht erzeugen
Druck Image:Print24.png F12 Zugehöriges Dokument drucken
Druckvorschau Image:PrintPreview24.png Alt-Umschalt-P
Schließen Image:End24.png Alt-X Fenster schließen
Abmelden Image:Logout24.png Alt-Umschalt-L Alle Fenster schließen und öffnen der Anmeldemaske
Anwendung beenden Image:Exit24.png Alt-Umschalt-X Anwendung beenden
Bearbeiten
Neuer Eintrag Image:New24.png F2 Neuen Eintrag anlegen
Änderungen sichern Image:Save24.png F4 Eintrag sichern
Eintrag kopieren Image:Copy24.png Umschalt-F2 Eintrag kopieren und einfügen
Eintrag löschen Image:Delete24.png F4 Eintrag löschen
Ausgewählte Einträge löschen Image:DeleteSelection16.png Strg-D Ausgewählte Einträge löschen
Änderungen ignorieren Image:Ignore24.png ESC Änderungen ignorieren
Einträge aktualisieren Image:Refresh24.png F5 Einträge aktualisieren
Eintrag Suchen Image:Find24.png F6 Suchmaske öffnen


Ansicht Alt-A
Produkt-Info [[Image:]] Alt-I Produkt-Informationen
Geschäftspartner-Info [[Image:]] Alt-Umschalt-I Geschäftspartner-Informationen
Zeitplan-Info [[Image:]] Zeitplan-Informationen
Auftrags-Info [[Image:]] Auftrags-Informationen
Rechnungs-Info [[Image:]] Rechnungs-Informationen
Lieferungs-Info [[Image:]] Lieferungs-Informationen
Zahlungs-Info [[Image:]] Zahlungs-Informationen
Kassen-Info [[Image:]]
Ressourcen-Info [[Image:]]
Asset-Info [[Image:]]
Anlage [[Image:]] Anlage zu diesem Eintrag erstellen oder anzeigen
Chat [[Image:]]
Ausgeblendete Einträge [[Image:]] Ausgeblendete Einträge wieder anzeigen (Zeitbereich auswählen)
Liste/Einzelsatz [[Image:]] Umschalten zwischen Listenanzeige oder Einzelsatzanzeige
Gehe Alt-G
Erster Eintrag [[Image:]] Alt-Bild auf Erster Eintrag
Vorheriger Eintrag [[Image:]] Alt-Oben Vorheriger Eintrag
Nächster Eintrag [[Image:]] Alt-Unten Nächster Eintrag
Letzter Eintrag [[Image:]] Alt-Bild ab Letzter Eintrag
Übergeordneter Eintrag [[Image:]] Alt-Links Übergeordneter Eintrag
Detail-Eintrag [[Image:]] Alt-Rechts Detail-Eintrag
Zoom (wo referenziert) [[Image:]]
Anfrage [[Image:]]
Archiv [[Image:]]
Menü [[Image:]] Menü
Extras Alt-E
Rechner [[Image:]] Taschenrechner
Kalender [[Image:]] Kalender
Editor [[Image:]] Editor
Script [[Image:]] Script
Fenstergröße setzen [[Image:]]
Aktive Workflows [[Image:]]
Einstellungen [[Image:]]
Fenster Alt-F
Andere Fenster schließen
Alle Fenster schließen
Offene Fenster Liste aller geöffneten fenster, Berichte usw.
Gerade ausgewähltes Fenster [[Image:]]
Hilfe Alt-H
Hilfe [[Image:]] F1 Hilfe
Online [[Image:]] Online
E-Mail senden [[Image:]] E-Mail an Support senden
Über [[Image:]] Über

Symbolleiste

Kommando
Symbol
Funktionstaste
Kurzbefehl
Menü
Beschreibung
Änderungen ignorieren Image:Ignore.jpg ESC Bearbeiten

- Rückgängig

Änderungen rückgängig machen
Hilfe Image:Help24.jpg F1 Hilfe

- Hilfe

Mehr Informationen erhalten
Neu Image:New24.jpg F2 Strg-N Bearbeiten

- Neu

Neuen Eintrag erzeugen
Löschen Image:Delete24.jpg F3 Strg-X Bearbeiten

- Löschen

Eintrag löschen
Ausgewählte Einträge löschen Image:DeleteSelection24.jpg Strg-D
Sichern Image:Save24.jpg F4 Bearbeiten

- Speichern

Eintrag sichern
Aktualisieren Image:Refresh24.jpg F5 Bearbeiten

- Aktualisieren

Einträge aktualisieren
Suchen Image:Find24.jpg F6 Strg-F Ansicht

- Suchen

Suchmaske anzeigen
Anlage Image:Attachment24.jpg F7 Ansicht

- Anlage

Anlage zuordnen oder anzeigen
Chat Image:Chat24.jpg
Liste/Eintrag Image:Multi24.jpg F8 Ansicht

- Liste / Einzelsatz

Umschalten zwischen Listenanzeige oder Einzelsatzanzeige
Ausgeblendete Einträge Image:History24.jpg F9 Ansicht

- Ausgeblendete Einträge

Anzeigen der ausgeblendeten Einträge (öffnet Auswahldialog)
Menü Image:Home24.jpg F10 Gehe

- Menü

Menü anzeigen bzw. in den Vordergrund holen
Übergeordneter Eintrag Image:Parent24.jpg Alt-links Gehe

- Übergeordnet

Übergeordneten Eintrag anzeigen
Detail-Eintrag Image:Detail24.jpg Alt-rechts Gehe

- Detail

Detail-Eintrag anzeigen
Erster Eintrag Image:First24.jpg Alt-Bild auf Gehe

- Erster Eintrag

Ersten Eintrag anzeigen
Vorheriger Eintrag Image:Previous24.jpg Alt-auf Gehe

- Vorheriger

Vorherigen Eintrag anzeigen
Nächster Eintrag Image:Next24.jpg Alt-ab Gehe

- Nächster

Nächsten Eintrag anzeigen
Letzter Entrag Image:Last24.jpg Alt-Bild ab Gehe

- Letzter Eintrag

Letzten Eintrag anzeigen
Bericht Image:mDocAction.jpg F11 Alt-P Datei

- Bericht

Bericht für diesen Eintrag anzeigen
Archiv Image:Archive24.jpg Gehe

- Archivierte Belege und Berichte

Öffnet den Archivbetrachter
Druckvorschau Image:PageSetup24.jpg Alt-Umschalt-P
Druck Image:Print24.jpg F12 Strg-P Datei

- Druck

Dokument drucken
Zoom Image:Zoom24.jpg
Aktive Workflows Image:Workflow24.jpg
Anfrageverfolgung Image:Request24.jpg
Produkt-Information Image:Product24.jpg Alt-I Anzeige

- Produkt Info

Produkt-Information anzeigen
Fenster schließen Image:End24.jpg Alt-X Datei

- Fenster schließen

Dieses Fenster schließen

Register

Die Register auf der linken Seite (oder oben, wie auf dem Hauptfenster) können Sie mit den Tastenkombinationen Alt-1, Alt-2, ... entsprechend ihrer Reihenfolge von oben nach unten (bzw. von links nach rechts) aufrufen.

Eingabebereich

Im Eingabebereich gibt es verschiedene Arten von Feldern zur Dateneingabe:

  • Selektionsfeld - z.B. „Aktiv“
  • Freitextfeld für kurze Texte - z.B. „Name“
  • Freitextbereich über mehrere Zeilen für längere Texte - z.B. „Bemerkung“
  • Zahlenfeld, erkennbar am kleinen Taschenrechnersymbol am Ende des Feldes - z.B. „Menge“
  • Datumsfeld, erkennbar am kleinen Kalendersymbol am Ende des Feldes – z.B. „Liefertermin“
  • Auswahlfeld, erkennbar am Pfeil am Ende des Feldes – z.B. „Zahlungskondition“

Kontextmenü

Auf den meisten Feldern können Sie mit der rechten Maustaste ein Kontextmenü öffnen.


Kommando
Symbol
Beschreibung
Zoom (Definition) [[Image:]] Fenster zur Definition für diesen Eintrag öffnen
Aktualisieren [[Image:]] Auswahlmöglichkeiten für dieses Selektionsfeld aktualisieren
Standardwert [[Image:]] Derzeitigen Wert als Standardwert für dieses Feld auf Mandanten-, Organisations- oder Fenster-Ebene setzen
Editor [[Image:]] Gesonderten Editor öffnen

Hinweisfeld

In diesem Bereich am unteren Ende des Fensters werden Hinweistexte wie z.B. auf einem Auftrag der Text „2 Zeilen – 34,57 – Gesamt: 36,99 EUR“ ausgegeben oder auch Fehlermeldungen wie „Periode geschlossen“.

Datensatz-Info

[[Image:||
Datensatz-Info
]]

Jedes Fenster in ADempiere zeigt Ihnen rechts unten eine Orientierungshilfe und den aktuellen Status des gerade geöffneten Datensatzes an.

In dem Beispiel sehen Sie, dass Sie sich auf dem 13. Datensatz von insgesamt 29 befinden.

Das „+” vor diesen Ziffern zeigt an, dass dieser Eintrag neu eingefügt wurde, der „*” zeigt an, dass dieser Datensatz geändert wurde.

Weitere Symbole

Einige Fenster bieten zusätzliche Funktionen mit den folgenden Symbolen:


Kommando
Symbol
Beschreibung
OK – Akzeptieren [[Image:]] Akzeptieren und Dialog schließen – oft Standard-Schaltfläche (ausgelöst, wenn ENTER gedrückt)
Abbrechen - Ablehnen [[Image:]] Ablehnen und Dialog schließen
Verarbeiten [[Image:]] Verarbeitung (eventuell als asynchroner Hintergrundprozess) starten
Exportieren [[Image:]] Daten exportieren
Importieren [[Image:]] Daten importieren
Kalender [[Image:]] Datum über Kalender auswählen
Seite einrichten [[Image:]] Einstellungen anpassen
EMail [[Image:]] Ausdruck als PDF-Anhang versenden

Nicht-dynamische Fenster

Eine weitere Art von Fenstern – sogenannte nicht-dynamische Fenster (oder Form auf Englisch) - werden nicht durch Einträge im Application Dictionary sondern durch Java-Quellcode definiert. Ein solches Fenster enthält nur die Menüleiste und dazu häufig mehrere Register und Auswahlfelder und startet am Ende der Auswahl einen Prozess.

[[Image:||
Fenster Rechnungen generieren (manuell)
]]


Bericht

Image:Iconreport.png Dieses Symbol weist auf den Aufruf eines Berichtes hin.

Der Aufruf eines Bericht erzeugt eine Auswertung von Datensätzen nach bestimmten Kriterien – z.B. eine Rechnungsübersicht nach Zeitbereich oder Geschäftspartner. Das Ergebnis ist meist eine Liste im Querformat, die angepasst und ausgedruckt werden kann.

[[Image:||
Bericht Lagerbestand - Detail
]] [[Image:||
Bericht - Parameterabfrage
]]

Der Aufruf eines Berichtes startet meist als erstes ein Abfragefenster zur Eingrenzung der Parameter. Eine einfache Version bietet der Aufruf Geschäftsbeziehungen > Geschäftspartner – Offen.

In diesem Fall ist nur der Geschäftspartner für den Bericht auszuwählen. Nach der Auswahl von Joe Block wird der Bericht seiner offenen Beträge angezeigt.

[[Image:||
Bericht Offene Beträge
]]

Die hier verwendeten Funktionsymbole sind bereits in den Tabellen weiter oben aufgelistet.

Prozess

Image:Iconprocess.png Dieses Symbol weist auf den Aufruf eines Prozesses hin.

Einen Prozess kann man sich als eine Aufgabe vorstellen, die in der Datenbank oder auf dem Server abläuft, wie z.B. das Erstellen von Rechnungen aus offenen Aufträgen.

Der Aufruf eines Prozesses startet ein Abfragefenster – ähnlich wie beim Aufruf eines Berichtes. Als Beispeiel dient hier der Aufruf des Prozesses Beschaffung > Bestellung aus Bedarf erzeugen.

[[Image:||
Prozess - Abfragefenster
]]

Klicken Sie - wenn Sie alle Paramter gesetzt haben – auf Start. Solange der Prozess arbeitet erscheint ein Statusfenster. Anschließend wird das Ergebnis angezeigt.In diesem Fall eine Übersicht der durch den Prozess erzeugten Bestellungen.

[[Image:||
Prozess - Ergebnis
]]

Workflow

Image:Iconworkflow.png Dieses Symbol weist auf den Aufruf eines Workflows hin.

Ein Workflow definiert eine Reihe von Arbeitsschritten, deren Abarbeitungin einer bestimmten Reihenfolge nötig ist, um ein Ziel zu erreichen.

Ein Workflow fasst eine Reihe von Funktionen zusammen, die in einer bestimmten Reihenfolge nacheinander ausgeführt werden sollten, um ein bestimmtes Ergebnis zu erzielen. Nehmen wir als Beispiel den Workflow Einrichtung Vertrieb an. Sie öffnen ihn durch Mausklick auf Vertrieb > Vertrieb und Marketing > Einrichtung Vetrieb. Der Workflow öffnet sich im so benannten Register des Hauptfensters.

[[Image:||
Workflow-Beispiel
]]

In der oberen Hälfte des Fensters sehen Sie eine grafische Darstellung des Workflows. Es sind in diesem Beispiel die Schritte, die vor der Nutzung der Vertriebsfunktionalität ausgeführt werden sollten.

Im unteren Teil des Fensters sehen Sie einen beschreibenden Text. Um durch die verschiedenen Schritte zu navigieren und entsprechende Fenster zu öffnen, können Sie entweder die benannten Schaltflächen im oberen Bereich oder die Navigations-Symbole im unteren Bereich verwenden.


Symbol
Beschreibung
[[Image:]] Erster Arbeitsschritt
[[Image:]] Vorheriger Arbeitsschritt
[[Image:]] Nächster Arbeitsschritt
[[Image:]] Letzter Arbeitsschritt

Hilfe

Kontexthilfe

Bewegen Sie die Maus auf die Beschriftung eines Feldes, einer Schaltfläche oder eines Registers. Nach kurzer Zeit erscheint ein erklärender Text zu diesem Element.

Hilfefenster

Zu jedem Fenster gibt es auch eine ausführlichere Beschreibung. Öffnen Sie diese über den Eintrag Hilfe im Hilfe-Menü oder das entsprechende Symbol in der Symbolleiste oder drücken Sie die F1-Taste.

[[Image:||
Hilfe-Fenster
]]

Ein Hilfe-Fenster öffnet sich und zeigt alle Informationen zum aktuellen Fenster, in dem Sie sich gerade befinden, an (in diesem Fall das Fenster Bestellung). Das Hilfe-Fenster enthält Informationen über Fenster, Register und Felder. Sie können im Hilfe-Fenster blättern oder die Links anklicken.

Einstellungen

Im PullDown-Menü Extras finden Sie den Menüpunkt Einstellungen. Damit öffnen Sie ein Fenster, das eine Anzahl von Selektions- und Auswahlfeldern besitzt, mit denen Sie Aussehen und Funktionalität des ADempiere-Client für sich anpassen können.

Register Einstellungen

Auf diesem Register können Sie einstellen, wie sich ADempiere bei der Anmeldung verhalten soll.

Im Bereich Fenster geben Sie vor, ob Sie bestimmte Daten angezeigt bekommen wollen und wieweit ADempiere automatisch für Sie arbeitet.

Im Bereich Verbindung können Sie das Übertragungsverhalten zwischen Client und Server beeinflussen.

Bei Problemen können Sie im Bereich Protokoll-Information bestimmen, wie detailliert ADempiere die Verarbeitung protokollieren soll.

[[Image:||
Register Einstellungen
]]

Unter Drucken können Sie den Standarddrucker vorgeben und festlegen, dass Sie vor dem Druck immer erst zur Kontrolle eine Bildschirmanzeige haben möchten.

Das hier eingestellte Datum wird als Vorbelegung für alle neuen Datensätze verwendet.

Register Nutzeroberfläche

[[Image:||Register Nutzeroberfläche]]

Auf dem Register Nutzeroberfläche können Sie auswählen, wie ADempiere aussehen soll. Sie können verschiedene Stile und Farben auswählen und Ihre Auswahl vor dem Speichern auf dem Bildschirm überprüfen.

Register Info

Dieses Register zeigt Ihnen die Einstellungen Ihrer Anmeldung und des genutzten Servers an.

Register Kontext

Auf diesem Register finden Sie Informationen, die bei der Anpassung und Weiterentwicklung oder der Fehlerfindung hilfreich sein können.

Register Fehler

[[Image:||Register Fehler]]

Wenn Ihnen bei der Arbeit mit ADempiere ernsthafte Verarbeitungsfehler begegnen werden Sie auf diesem Register sehr wahrscheinlich Einträge sehen, die die Eingrenzung und Behebung unterstützen. Sie können diese Informationen mit Hilfe der entsprechenden Schaltflächen per EMail versenden oder in einer Datei abspeichern.

Personal tools