PLJAVA

From ADempiere ERP Wiki

Jump to: navigation, search

PLJAVA is not longer needed in ADempiere version >= 3.5.3a !!!

You don't need pljava for ADempiere since version 3.5.3a ! Just skip the steps in installation process for pljava.

Abstract:

PLJAVA is required in an ADempiere / PostgreSQL installation upto version 3.5.3a. PLJAVA is used by some functions like "ProduktInfo", which could be used as a test-case to verify that pljava has been installed properly and is working correctly.

  • One has to understand, that pljava implements the Java Native Interface (JNI), thus using java $CLASSPATH and operating system $LD_LIBRARY_PATH. The combining part between the java virtual machine and the real operating system is libjvm.so (Linux) or libjvm.dll (Windows). If libjvm.so (libjvm.dll) is not found, than pljava.so will not be found either. If pljava.so is not known to PostgreSQL via postgresql.conf, than PostgreSQL is looking in ../lib for pljava.so.
  • A more detailed document can be found here - File:HOWTO-pljava-ADempiere-v02.pdf.


Related links:

Personal tools