Difference between revisions of "Talk:Branch GlobalQSS 361"

From ADempiere ERP Wiki
Jump to navigationJump to search
Line 47: Line 47:
: See compatibility with older Mercurial versions: [http://mercurial.selenic.com/wiki/UpgradeNotes#A1.9:_minor_changes.2C_drop_experimental_parentdelta_format contrib/hg-ssh from older Mercurial releases will not be compatible with version 1.9, please update your copy.]
: See compatibility with older Mercurial versions: [http://mercurial.selenic.com/wiki/UpgradeNotes#A1.9:_minor_changes.2C_drop_experimental_parentdelta_format contrib/hg-ssh from older Mercurial releases will not be compatible with version 1.9, please update your copy.]
: --[[User:Rsashka|rsashka]] 11:44, 20 July 2011 (UTC)
: --[[User:Rsashka|rsashka]] 11:44, 20 July 2011 (UTC)
:: Thanks Yogan and Aleksandr for your notes making this page more useful.  --[[User:CarlosRuiz|CarlosRuiz_globalqss]] 16:58, 20 July 2011 (UTC)

Revision as of 16:58, 20 July 2011

What we want to avoid

  • I am unsure of this first point of 'People committing incomplete or untested things pushing others to complete/review/fix their underdeveloped code'
I feel in the Bazaar it is not only allowed but encouraged to do so as the maxim goes, "Release Early, Release Often". Sure, every positive maxim has its extremities. Of course i know what you mean that it is been exploited. If so, then i suggest better to use, 'Exploiting the 'Release Early, Release Often' principle by pushing others to do their incomplete work. - Redhuan D. Oon 03:37, 12 November 2010 (UTC)
Thanks Redhuan for your comment, I added a clarification line, I hope that answer your comment, if not, please keep up this discussion, it's very important for an initial clear definition about what we're looking for.
--CarlosRuiz_globalqss 04:11, 12 November 2010 (UTC)

Do I understand?

CarlosRuiz_globalqss, please excuse for my English ;-)

  • This branches - an attempt to stabilize the corrections into the mainline of the project that the system would be more stable?
  • In patches from Global QSS includes fixes from the main project ever, so these updates should be put in place patches.jar? (If I setup the patches from the Global QSS, then the usual patches has already unnecessary?) --rsashka 05:25, 13 November 2010 (UTC)
Hi Rsashka, thanks for your interest on this branch.
> "an attempt to stabilize the corrections into the mainline of the project that the system would be more stable?"
  • That's the goal, peer review and QA. The more people involved with the same vision, the more we advance on this objective.
> "then the usual patches has already unnecessary"
  • I'm not sure what are you calling "usual" patches. Just let me tell you that there are things committed on trunk that are against the goal of this branch, so, consequently those commits won't pass to this branch.
  • For example, changing columnnames is breaking backward compatibility for lots of reports created out there (that's against product management). Another example, cascade delete is dangerous.
  • That makes trunk and other patches probably incompatible with this branch.
--CarlosRuiz_globalqss 15:01, 13 November 2010 (UTC)
> "That makes trunk and other patches probably incompatible with this branch."
  • Backwards compatibility is also partly a question of quality. The general idea is clear.
  • I very well understand your decision about having brunch with one commitera. Сan not agree on a few people, himself faced with this, when added and rollback Russian regions ;-) --rsashka 16:44, 13 November 2010 (UTC)
About rollback of russian regions that was not caused because of quality, but because of enforcement of policies, the migration script for russian regions is one of the pending tasks I have for this branch. --CarlosRuiz_globalqss 16:59, 13 November 2010 (UTC)

Eclipse and Mercurial

Hi Carlos, We will always be grateful to you and thanks for sharing your repository.

I tried setting my elipse(Indigo) with Mercurial(1.9) on Ubuntu 10.10 and encountered the following issues:

a) The mercurial update for eclipse as changed to: http://cbes.javaforge.com/update. One also has to first signup at JavaForge.

b) The Mercurial update did not work until I loaded the latest version on my system.....as per the following link: [1]

c) I then had a security certificate problem and resolved this my making changes to my mercurial config file: /etc/mercurial/hgrc......as per the following link: [2]

Ciao Yogan


> "I tried setting my elipse(Indigo) with Mercurial(1.9)"
See compatibility with older Mercurial versions: contrib/hg-ssh from older Mercurial releases will not be compatible with version 1.9, please update your copy.
--rsashka 11:44, 20 July 2011 (UTC)
Thanks Yogan and Aleksandr for your notes making this page more useful. --CarlosRuiz_globalqss 16:58, 20 July 2011 (UTC)